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MODULE -1: INTRODUCTION 

1.1. Introduction to Geospatial Technology and GIS  

1.1.1. Introduction to Geospatial Technology (refer the PowerPoint presentation)  

1.1.2. Introduction to GIS (refer the PowerPoint presentation) 

1.2. Overview of Spatial Data  

1.2.1. Source and Nature of Spatial Data 

The sources for spatial data can be from different sources including Field observation/measurement, 

GPS based data collection, Remote sensing and software based derivations like map digitization. Now 

days Satellite based data acquisition is providing continues image products for almost all areas of the 

world at different spatial resolutions. The field based data collection also remain important in 

providing ground based accurate measurements which often helps to calibrate space based products. 

For climate data these two sources plays a crucial role and the limitation of one is also substantiated 

by the other. For instance, issues related to accuracy on the satellite products can be verified by the 

ground station readings while the discrete nature of data obtained from ground observations can be 

reasonably interpolated with the help of satellite data products which provides a continuous raster data 

for an area.       

 

1.2.2. Spatial and temporal resolutions 

Image resolution is a factor of precision/fineness of pixels to represent certain portion of the earth 

surface. There are two categories of image resolution that are very important to understand in spatial 

data and these are spatial and temporal resolution. The spatial resolution categorically refers to the 

size of a pixel used to represent certain area of the surface. The bigger the pixel size, the low the image 

resolution. For example, Image with 5km x 5km resolution means 25 square kilometer of area is 

represented by one pixel. Compared to 50km x 50km it can be said that the previous image has higher 

resolution. On the other hand, temporal resolution refers to the repetitiveness of the data capture like 

hourly, daily, decadal, monthly, annual etc.  
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Understanding the spatial and temporal resolution is quite essential before defining a methodology in 

any of the natural systems modeling including climate.  Some image resolutions are appropriate only 

for large areas and for small areas high resolution products are recommended.  

Some climate data from different sources are summarized for your further exploration 

Satellite/Product Name  Spatial Resolution  Temporal resolution  Remark  

CHIRPS 2.0 ~5km x 5km Decadal  Blend 

TAMSAT ~4km x 4km  Daily  Sat. 

TRMM ~25kmx25km 3hrs  Sat. 

GPM ~10km x10km  “ Sat. 

WorldClim ~1km x1km   Station interpolation 

Landsat  30m x 30m /15m  Multi-spec Image 

Sentinel 2 10 x 10m   Multi-spec image 

  

  

50km                             1km                                     30m                                     0.6m 

For the greater horn region all the above products are available in common raster file formats. Some 

of the limitations in using these products are technical and professional capacity to manipulate data 

and make a meaning to explain some of the natural and human induced phenomena around us.   
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1.3. GIS Data Models and Coordinate Geometry  

1.3.1. GIS Data Models 

The nature of the spatial data can be of vector or raster format. Vector data formats are used to 

represent discrete type of data and often represented by point, line and/or polygon. Raster data types 

are used to represent continuous data types like rainfall, temperature, topography...etc. The smallest 

entity of a vector is a point whereas for raster it is a pixel. The type of data modeling depends on the 

nature of the data, scale of the map, and our preference for the analysis that follows.  However, it is 

good to remember that conversion of raster to vector or vise-versa is always possible although it might 

compromise the quality/form of the original data. For example, if you convert a raster to vector the 

edge may be generalized and may not follow the exact boundaries. It is highly recommended to avoid 

back and forth conversion of your data between vector and raster unless you are required to do so. It 

is also worth to remind you the many raster file formats which sometimes creates obstacles to data 

processing as all data formats are not compatible to the softwares we may choose to use.  

              

                          Raster Data Model                                                         Vector Data Model  

1.3.2. Coordinate systems  

Any data that represent the location/position is called spatial data.  The most common ways of representing 

spatial data is through the use of X and Y or longitude and latitudes which are obtained through the system 

called coordinate system. There are two categories of coordinate systems and these are Geographic coordinate 

systems (uses degrees minutes and seconds) and projected coordinate systems (uses meter as a unit of 

measurement often with six/seven digit numbers).   

(a) Geographic Coordinate Systems 

It uses Latitudes (0-90oN-S) and Longitudes(0-180oE-W)  and the Latitudes are measuring the distance from 

the equator( Y-dimension) and Longitudes are measuring distance from Greenwich (X-dimension) either be 

positive on the north hemisphere or negative on the south side of the equator are measured using degrees, 

minutes and seconds (° , ‘ , ’’).  
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(b) Projected Coordinate Systems 

This system by Mercator divides the globe in to 60 grids called zones and uses meter as a unit of measurement. 

 

1.4. Overview of Quantum GIS Software 

Quantum GIS often called QGIS is the leading open source GIS software and have quite many functionalities. 

In addition to the various toolboxes that one can use for manipulating spatial data, the software is also a 

launching pad for many other open source GIS software like GRASS, SAGA, Python, R, TauDEM, and GDAL. 

The software is simple and provides a state of the art facilities as the best open source GIS software available 

to the user community.  
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Many of the tools and procedures are straightforward and all the tutorial documents on the tools and functions 

are available at http://www.qgistutorials.com/en/.  

 

 

  

http://www.qgistutorials.com/en/
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MODULE -2: CREATE, EDIT AND MODIFY SPATIAL AND 

ATTRIBUTE DATA 

2.1. Create polygon, line and point features  

The purpose of this section is to provide guidance on how to create polygons, line, and point also 

known as vector features using QGIS. These features are one of the input files required for further 

analysis according to the users’ need. The instructions described here were mostly taken from the 

QGIS User Guide, and adapted to meet our needs of the training. 

Input: Any georeferenced image file (samples) or WMS layer containing features you would like to 

trace. For this practical we will use the Google satellite image, to do so, we need to add the OpenLayers 

Plugin.  

1. Go to Plugins > Manage and Install Plugin and type OpenLayers Plugin. Then Click install. Other 

forms of adding images are through (Layer > Add layer > Add Raster Layer) or WMS layer (Layer 

> Add Layer > Add WMS Layer). 

2. Then click on Web > OpenLayers Plugin > Google Maps > Google Satellite, then zoom to the area 

of interest. 

 

3. To create the new empty layer for your vector feature; select Layer > Create Layer > New 

Shapefile Layer.  You will be prompted to confirm the Type of feature 

you want to create (point, line, or polygon). By default, the Coordinate Reference System used is 

WGS 1984 (read more), but you can change this if you wish. 

4. You will then be prompted to give: 

http://geo.nls.uk/urbhist/guides_maps_wms_list.html
http://geo.nls.uk/urbhist/guides_coordinates.html
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 The Name of the Attribute you are tracing 

e.g. Name, Type, Code etc. 

 The Type of the Attribute – e.g. Text, 

Whole Number 

 The Width of the field for the Attribute. 

Select Add to Attribute list 

 The Shapefile Name to save the layer. 

 

 

 

 

 

4. The shapefile will be added to the Layers Panel on the 

left hand side. RIGHT click on the layer (streams or 

rivers) to bring up a menu of options connected to it. 

5. To add or edit features, select the Toggle editing 

or from the top main tool bar   

 

6. For capturing POINTS  

 Click on the point button 

 Click points at your chosen location, and choose a name for each point feature 

 Click on Toggle editing to save the vector point layer 

7. For capturing LINES  

 Click on the point button 

 Click a set of points along the line. RIGHT click when you have reached the final point to 

finish, and choose a name for the line feature 

 Click on Toggle editing to save the vector line layer 
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8. For capturing POLYGONS  

 Click on the point button 

 Click a set of points along the perimeter of the polygon. RIGHT click when you have reached 

the final point to finish, and choose a name for the polygon 

 Click on Toggle editing to save the polygon layer 

9. For editing points, lines and polygons: 

 The Move Feature button  allows a whole feature to be moved to a new position 

 RIGHT click on the layer in the Table of Contents and select Open attribute table to view and 

edit the information connected to the features 

 RIGHT click on the layer in the Table of Contents and select Save As to save the layer in a 

number of formats, including Keyhole Markup Language (KML).  

10. You can save your current open layers and features at any time by using the Save 

Project button.  

NOTE: Output options: A shapefile or (Keyhole Markup Language) KML file with vector features. 

A shapefile actually consists of several files (more info). The following three are required: 

1) .shp file containing the feature geometries 

2) .dbf file containing the attributes in dBase format 

3) .shx index file 

4) .prj file contains the projection information (# not mandatory)  

KML is a file format used to display geographic data in an Earth browser such as Google Earth. 

2.2.2.2. Create attribute tables to features/Populate data  

One way to create attribute table is shown in section 2.1 above as component of creating new 

shapefiles. You call also add a new field on the existing attribute table to the existing feature class 

(point, line, and polygon).  

 Load the vector file (Water_points.shp). Go to Layer > Add Layer> Add Vector Layer. 

 Browse to the input data location folder. Select Water_points.shp 

 Right-click on the layer and select Open Attribute Table. 

 Activating the Edit tool and Add a new field after which you can edit accordingly. 

 

http://www.esri.com/library/whitepapers/pdfs/shapefile.pdf
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2.3.2.3. Import tables to GIS data layers (Join) 

This exercise is to show how tabular data (Elevation_data.csv) to the attribute of a shapefile 

(Water_points.shp) and then used for further analysis. Read more link.  

 Open the .csv file in a text editor. Examine the attributes of the csv file and identify a unique 

and common attribute to each (csv file and the shapefile).   

 We could import this CSV file without any further action and it would be imported. But, the 

default type of each column would be a String (text). Having it imported as text would not 

allow us to run any mathematical operations on the column with numbers. We therefore need 

to create a sidecar file with a .csvtextension (.csvt) to tell QGIS to import the field as a number. 

This file will have only 1 row specifying data types for each column. Save this file as the 

original file but with a different extension (Elevation_data.csvt). 

 - OR-   

 Now import the CSV file to QGIS. Go to Layer > Add Layer > Add Delimited Text Layer. 

 Browse to the folder containing the CSV file and select it. Since we are importing this as a 

table, we must specify that our file contains no geometry. Select the No geometry (attribute 

only table) option. Click OK.  

 Select the Water_point layer, Right-click on it and select Properties. 

 In the Layer Properties dialog, select the Joins tab. Click on the button at the bottom to 

create a new table join. 

 In the Add vector join dialog, select Elevation_data as the Join layer. Select the fields with 

unique ids in both the shapefile and the CSV. Then Click Okay. 

 Close the Layer Properties dialog. At this point, the fields from the CSV file are joined with 

the shapefile. Right-click on the Water_point layer and select Open Attribute Table.  

 

2.4. Import GPS data to GIS format  

The GPS data comes in a table i.e. text file. If the data has a list lat/long coordinates, you can easily 

import this data in your QGIS. 

 Examine your tabular data source if it contains Latitude and Longitude. 

 Click on Layer > Add Layer > Add Delimited Text Layer to import the file. 

 In the dialog, click on Browse and specify the path to the text file. In the File format section, 

select Custom delimiters and check Tab. The Geometry definition section will be auto-

populated if it finds a suitable X and Y coordinate fields. In our case they are LONGITUDE 

and LATITUDE. You may change it if the import selects the wrong fields. Click OK 

http://www.qgistutorials.com/en/docs/performing_table_joins.html
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 An error may occur as a result of missing X and Y fields. Just ignore it for purposes of this 

exercise. 

 A Coordinate Reference System Selector will ask you to select a coordinate reference system. 

Select WGS 84. Click OK. 

 The data will be imported and displayed in the QGIS canvas. 
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MODULE -3: BASIC GEOPROCESSING AND SPATIAL ANALYSIS  

3.1. Basic Geoprocessing and Spatial Analysis  

Rational: The main rational for using geoprocessing tools and spatial analysis is to try to answer some space 

based questions and get more information out of your data. 

Geoprocessing is a GIS operation used to manipulate spatial data. A typical geoprocessing operation takes an 

input dataset, performs an operation on that dataset, and returns the result of the operation as an output dataset. 

All data preparation and manipulation can be called Geoprocessing. We will see some of the most important 

tools under this topic which really helps you answer spatial questions.  

a) Buffer Analysis   

Buffer analysis is one of the most important geoprocessing tools that help to identify proximity of places from 

a reference layer. For instance, if you wish to identify road networks with in 3km of water points you can 

easily identify them. Let’s create a buffer of 3 km from a water point’s data and see which roads give acess to 

the nearest water points.  

1) Add Water points  data layer from C/RPLRP_GIS/  folder   

2) Under the main menu go to Vector > Geoprocessing Tool >  click buffer 

3) Set Water points as input layer and since the data is in Geographic coordinate give 0.05 iunder distance 

which is approx... 5km buffer.  

4) save it under your My-Work under C/RPLRP_GIS/ folder with file name 5km buffer.shp 

5) Zoom-in to the stations to see the buffer around the stations 

 

 What if you want a different buffer distance for each based on certain value like type of water source?   

OR You want to create highly accessible, Accessible and inaccessible map depending on distance?  
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b) Intersect    

This tool is one of the essentials in GIS and helps to get not only the common areas between two layers but also 

to juxtapose the attribute information of one layer next to the other. Example, all the Water Points data have 

category. So, if you wish to know the county/zone of each of the points you can interest the water points with 

Cluster 2 layer.  

1) Load Cluster 2 and Water points layer in to QGIS  

2) Go to Vector > Geoprocessing Tool >  click Intersect  

3) Set the first Input vector layer Cluster 2 and in the second Water points 

4) Save it under My-Work folder with file name Intersect.shp 

5) Now you can open and see that the attribute table contains County information for all stations  

 Can you categorize stations based on the county/Woreda one they are located in?  

c) Clip  

 

This is a famous tool to clip any of your spatial data (vector) with in your area of interest. Just as an example 

let’s clip the Water Points that are found in Obbu sub county in Kenya from Cluster 2. The procedures are as 

follows  

1) Use the select tool icon   in QGIS  and select Obbu.shp  

2) Once you select go to Vector > Geoprocessing Tool >  click Clip  

3) Set Water points as input vector layer and Cluster 2 as Clip layer  

4) Tick the “use only selected feature” under Cluster 2 to limit clipping boundary to Obbu 

5) Save it under My_Work folder with Obbu water points.shp file name  

There are hundreds of geoprocessing tools in QGIS and all of them are designed to help you manipulate your 

spatial data to reach at certain results or simple make analysis of your data to make more meaning out of it 

depending on your need.  

Tip! You can add a base map to your layer by activating Open layer plugin from Web in the main menu   
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3.2. Spatial Analysis  

The rationale for spatial analysis science is to understand spatial distribution, variation, interaction and 

relationships of features or phenomena. According to Carleton College definition spatial analysis is a set of 

techniques for analyzing spatial data. The results of spatial analysis are dependent on the locations of the objects 

being analyzed. Software that implements spatial analysis techniques requires access to both the locations of 

objects and their attributes. The other description is from ESRI “Spatial analysis is how we understand our 

world—mapping where things are, how they relate, what it all means, and what actions to take. From 

computational analysis of geographic patterns to finding optimum routes, site selection, and advanced 

predictive modeling, spatial analysis is at the very heart of Geographic Information System (GIS) technology.”   

 

The goal of spatial analysis is to answer spatial questions which might be related to location, pattern, change, 

scenarios and others.  GIS softwares are designed to provide a state of the art tools to process data and answer 

such complex space based questions.  

There are hundreds of tools under the QGIS toolbox to help you carry out spatial analysis, however, it is very 

very important to first design a methodology or s model which needs to be supported with scientific methods 

to reach at a conclusion.  

a) Raster calculator  

This is a key spatial analysis tool when you are working on raster data. Almost all of the satellite data 

are raster based and thus, knowledge of this tool helps to run spatial analysis based on the pixel/cell 

value. For instance, you may be interested to know areas in your areas of interest that receive rainfall 

greater than 600 mm or between 300-1000mm a year. Raster calculator is also used to run equations.  

Now let’s start by identifying areas that receive average rainfall at greater than 600mm to see water 

deficit or surplus conditions in the region.  

1) Open Avg ppt.tif file under C/RPLRP_GIS in QGIS 

2) Go to Raster in the main menu and Click on Raster calculator  

3) In the dialogue box double click Avg ppt.tif and click on ‘ > ’ sign and write 700 

4) Set the output location C/RPLRP_GIS/Mywork and file name ppt_surplus and click Ok 

https://apps.carleton.edu/collab/spatial_analysis/SpatialAnalysis/
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What if you need areas that received rainfall between 250 and 1000mm?  

d) Extraction of point Values from images based on point station data  

This tool is very important when you want to extract data from a raster data set like elevation, 

rainfall, temperature, etc. The tool extracts pixel values of one or more layers which you can 

compare to establish some of your hypothesis or use as an input for further analysis.  

1) Make sure that the Avg ppt.tif and Water points data is still open in QGIS 

2) Now go to Processing  > Toolbox > and search Add grid values to points  

3) Under points set Water points and under the Grids select all  

4) In the result set the output file grid ppt_points under C/RPLRP/MyWork 

5) Click Run to execute the algorithm  

6) Once it finishes right click on the grid ppt_points and Open attribute table to see the results of your 

operation. You can see the rainfall values for all of the 739 water points.   

NB: These values can be compared to the station readings to see the quality of the rainfall estimates from 

satellite sources. You can also compare the quality of satellite data as compared to station data.  
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MODULE -4: WEB MAPPING APPLICATION   

4.1. Introduction to Web Mapping and ArcGIS Online  

4.1.1. Introduction to web Mapping and available platforms  

Web service, including web maps are resources that allows us to share our resources over the net (inter or 

intranet). The Desktop GIS helps to produce data layers, analysis and all other intermediately products but 

sometimes we also want to share your data online for selected user groups or to the whole world. In such case 

there are commercial and open source platforms which allows you to go online. The most common open source 

web mapping platforms (often require developer skills), according to oSGeo wiki are the following;  

(a) MapServer (http://www.mapserver.org/)  

(b) MapBuilder (http://docs.codehaus.org/display/MAP/Home)  

(c) Mapbender (http://www.mapbender.org/index.php/Main_Page)  

(d) Chameleon (http://www.dmsolutions.ca/technology/chameleon.html) 

(e) MapGuide (https://mapguide.osgeo.org/)  

(f) OpenLayers (http://www.openlayers.org/)  

(g) ka-Map(http://ka-map.maptools.org/)  

(h) CartoWeb(http://www.cartoweb.org/)  

(i) deegree iGeoPortal (http://www.deegree.org/)  
 

For this training, however, we will limit ourselves to the Web GIS platforms available with less developer skill 

and/or being used at IGAD/ICPAC. The two examples of web mapping platforms available are ArcGIS Online 

(commercial) and Geonode (Open Source) in addition to hundreds of other customizable open source 

applications. At ICPAC both of these products are being used due to the respective solutions they provide.  

 

GEONODE based ICPAC Geoportal (Open Source) 

http://www.mapserver.org/
http://www.mapserver.org/
http://docs.codehaus.org/display/MAP/Home
http://docs.codehaus.org/display/MAP/Home
http://www.mapbender.org/index.php/Main_Page
http://www.mapbender.org/index.php/Main_Page
http://www.dmsolutions.ca/technology/chameleon.html
http://www.dmsolutions.ca/technology/chameleon.html
https://mapguide.osgeo.org/
https://mapguide.osgeo.org/
http://www.openlayers.org/
http://www.openlayers.org/
http://ka-map.maptools.org/
http://ka-map.maptools.org/
http://www.cartoweb.org/
http://www.cartoweb.org/
deegree%20iGeoPortal
http://www.deegree.org/
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ArcGIS ONLINE based ICPAC Geosptial Apps (Commercial) 

4.2. Working on ArcGIS Online Web Mapping Platform  

4.2.1. Introduction to ArcGIS online interface  

ArcGIS Online is a web mapping platform which allows you to develop a map and apps that supports 

visualization of geospatial data (raster and vector) files. The major advantage of this platform is that it doesn’t 

require coding or developer skills and also provide charming visualization. The limitation is that it is 

commercial and limited storage (credit) capacity with basic or even standard subscriptions.   

There are two major components to develop a web mapping application; first, maps that allows you to upload 

and symbolize your data and the second component is what is called “Apps” which provide a platform to design 

/visualize your maps with different styles, choose widgets and corporate branding. The interface for both are 

given below 

  

 Apps 

Maps 
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You will be working with maps under section 4.2.2. and if time allows a demonstration of how to design ArcGIS 

App will be presented.  

Now let’s get in to the portal!  

4.2.2. Access Right and log in to RPLRP portal  

For this Training we have developed a trial RPLRP Web Mapping Application for you to exercise before you 

start working on the main portal. Follow these steps 

1) Make sure that you have internet and go to https://rplrp.maps.arcgis.com 

1) You will be asked to give your access credentials and provide User Name: RPLRPGIS   and 

Password: webtraining1 to access the un-official ArcGIS online portal of RPLRP developed for this 

training.  

2) Now click on the home page to go to the interface and  click on Water Point Data (RPLRP) canvas 

to launch the water points web application  

3) Please explore the features of the web mapping portal and discuss the cons and pros with the 

facilitator. You can also access the official ICPAC portal here https://icpac.maps.arcgis.com 

Now all the water point data will be removed and you will exercise on how to upload your GIS files in to a web  

4.2.3. Upload your data in to your ArcGIS online 

2) You are going to upload your water points to the web platform and the data is available under 

C:/RPLRP_GIS/Web folder  

3) Go to maps under the Home menu of the RPLRP training portal  and this opens a maps interface of 

ArcGIS Online  

4) Go to Add and click on Add layer from File  

 

5) Go to Add and click on Add layer from File and locate C:/RPLRP_GIS/WebMapping and select 

Cluster 1 to import layer 

 (Remember: You only can upload zipped shape file, CSV/Txt, GPX file in here) 

6) After few seconds your cluster 1 water points will be loaded as something like this  

https://rplrp.maps.arcgis.com/
https://icpac.maps.arcgis.com/
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7) Now you can manipulate the symbology in a way that suits your organizational brand or personal 

feel. Let’s work on symbology  

8) Click on a drop down menu under “Choose an attribute to show” and look for “CATEGORY” to 

classify your water points based on the type.  

9) Click on OPTIONS to manage the color, size and type of symbol you want to assign for each type of 

water points  

10) Click on the points to choose the shape, color and outline for it. Do this for all the four types of water 

points (Borehole/Well, Pan/Pond/Dam, Spring and Unknown).  

 

11) You can re-arrange the list by drag/drop to list them in the following order (Borehole/Well, 

Pan/Pond/Dam, springs and Unknown). 

12) Once you are done with that you can hit Ok and then Done to finish.  

Please import cluster 2 and 3 also and edit the symbology the way you feel appropriate.  

Add Cluster 1, 2 and 3 boundary also.  

The Final map looks something similar this 
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4.2.4. Data Editing in Web Map  

For consistency and ease of manipulation it is advisable to edit your data in desktop GIS platform using QGIS 

or other softwares. It is only when you are sure on your data integrity that you upload it to the web platform. 

However, you might want to edit your data due to addition of new sites or some might have wrong information 

which you want to correct in your web database. In such case you can edit the hosted service in many ways. 

Now let’s see how to edit water point data which is already hosted on the web.  

1) First go to the map you produced in the previous exercise and click on Edit Tool  

2) Now you might have local knowledge on location of water points or location of water points map 

from other sources, or you can see surface water from high resolution image. If your information is 

from the last source, you can select imagery from the Basemap   and zoom to see the 

location of Pan/Pond/Dam. If you see any discrepancy that means you need to Add new or Snap the 

existing water points to its correct position. Now let’s start by Adding a new ones. 

3) After you click on Edit and Zoom-in to your area of interest, select cluster 1 springs layer. This means 

you want to Add new water point which is a spring in Cluster 1. So, zoom to any visible river and 

click to add new water point source with attribute detail (Use your personal dummy information). 
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 What if the Water point category is marked as Bore hole but you have found out that 

it is a Pond? How can you edit this?  

You can select the point by holding Ctrl key and carefully click on the point, the table should open 

allowing you to change from one type to the other and also edit other attribute information.  

4.3. Updating the RPLRP Water Point Data Portal  

This training is organized to task you for the following activities once you go back to your duty 

station;  

Activity 1: Verify the water point types and Locations for your Country 

Activity 2: Add new water point data which is not captured already  

Activity 3: Modify any information which is not correct in the database   
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Reference 

QGIS User Guide Release 2.14 (5th July, 2017) http://docs.qgis.org/2.14/pdf/en/QGIS-2.14-

UserGuide-en.pdf 

 

http://docs.qgis.org/2.14/pdf/en/QGIS-2.14-UserGuide-en.pdf
http://docs.qgis.org/2.14/pdf/en/QGIS-2.14-UserGuide-en.pdf

